ClassLink Login / ClassLink.com Issues
Incident Report for ClassLink
Resolved
It appears all Amazon AWS Issues have been resolved. We apologize for the inconvenience this may have caused.
Posted 7 months ago. May 31, 2018 - 22:26 EDT
Monitoring
We are closely monitoring an Amazon AWS issue. It appears they were briefly having issues with their FileSystem. We are keeping an eye on the current status of AWS and at this time it appears the issue has been resolved. However, we are working on resolving the current issue with ClassLink.com not loading. We will update again soon once service has been restored.

https://status.aws.amazon.com/
Posted 7 months ago. May 31, 2018 - 18:20 EDT