Reports of issues with Google Chrome
Incident Report for ClassLink
Resolved
Hello,

One of our districts just forwarded the following message from Google:

[Fully resolved] Our engineering team indicates that the issue installing applications from the Chrome Webstore should now be resolved for all affected users. We thank you for your patience while we've worked on resolving the issue.
Posted about 1 month ago. Jan 12, 2018 - 14:11 EST
Update
Big thanks to all the school districts reporting issues with the Chrome Web Store - more reports came in from districts in Texas and several districts in Missouri. Hopefully Google resolves this soon. Happy Friday!
Posted about 1 month ago. Jan 12, 2018 - 14:01 EST
Update
Hello. So far school districts from NY, CA, and FL have reported issues with the Chrome Web Store.

Once again, here is a message to one of our districts:

"Google support has confirmed that there is a known issue with Chrome Web Store extensions deploying to some Chromebooks and Chrome browsers. Symptoms of the issue are extensions and applications from the Chrome Web Store are not appearing on Chromebooks and in Chrome for some users. Also, users affected are unable to add new extensions from the Chrome Web store. Google is in the process of determining the root cause of the issue and will provide updates as the issue is investigated."
Posted about 1 month ago. Jan 12, 2018 - 13:32 EST
Monitoring
Hello,

Another school district reported some of their Chromebooks and Chrome browser users had no browser extensions at all. But over the last few minutes, things are beginning to come back to normal. There have been no public announcements yet from Google but we will continue to update everyone as more clients update us with their experiences.

Thank you.
Posted about 1 month ago. Jan 12, 2018 - 13:10 EST
Identified
Hello everyone,

We received reports from a few clients that Google Chrome web store apps and extensions are not appearing.

One of our clients received this from Google Support:

"Google support has confirmed that there is a known issue with Chrome Web Store extensions deploying to some Chromebooks and Chrome browsers. Symptoms of the issue are extensions and applications from the Chrome Web Store are not appearing on Chromebooks and in Chrome for some users. Also, users affected are unable to add new extensions from the Chrome Web store. Google is in the process of determining the root cause of the issue and will provide updates as the issue is investigated."

This will impact the ClassLink Chrome extension and possibly impact other Google services.

We'll stay on top of this issue and provide updates.

Thank you.
Posted about 1 month ago. Jan 12, 2018 - 11:26 EST