Intermittent DUO MFA authentication errors

Incident Report for ClassLink

Resolved

The DUO MFA authentication errors have been resolved. Thank you for your patience while we worked with DUO to resolve the issue.
Posted May 20, 2026 - 09:41 EDT

Monitoring

The DUO MFA errors appear to have subsided. We are awaiting confirmation from DUO that a fix has been successfully applied and will post a final update once confirmed.
Posted May 20, 2026 - 07:32 EDT

Update

Update: We are actively working with DUO support on this issue. DUO has identified a potential cause and we are collaborating on a resolution. We will post updates as more information becomes available.
Posted May 19, 2026 - 16:42 EDT

Identified

We have identified the issue and we are working on implementing a fix for the DUO authentication errors.
Posted May 19, 2026 - 11:06 EDT

Investigating

We are currently investigating intermittent DUO MFA authentication errors affecting some users at login. Our team is actively working on a resolution and will provide updates as they become available.
We apologize for the inconvenience.
Posted May 19, 2026 - 08:44 EDT
This incident affected: LaunchPad (Active Directory Integration, Google Integration, Azure Integration).