LaunchPad Login Response Times
Incident Report for ClassLink
Resolved
It appears the issue has been resolved as response times are back to normal. The AWS status page hasn't been updated yet but we are monitoring their status. If anything changes, we will update this incident.
Posted Dec 07, 2021 - 14:07 EST
Identified
We've received reports of slow logins into LaunchPad. It appears our service provider, AWS, is experiencing technical difficulties. Other vendors are also experiencing issues with their products. It appears to be related to AWS. For the latest, please go to https://status.aws.amazon.com/
Posted Dec 07, 2021 - 13:01 EST
This incident affected: Sign in to ClassLink (Active Directory Integration, Google Integration, Azure Integration) and My Apps.