Slow Login into LaunchPad

Incident Report for ClassLink

Resolved

If you continue to experience issues logging in to LaunchPad, please go to the ClassLink Help Center (help.classlink.com) or email us at helpdesk@classlink.com.
Posted Apr 06, 2022 - 09:05 EDT

Monitoring

The issue has been addressed and we are monitoring the results. If you continue to experience issues, please go to the ClassLink Help Center or email us at helpdesk@classlink.com.
Posted Apr 06, 2022 - 08:44 EDT

Identified

A fix is being implemented to address the login issue. If a user logs in to LaunchPad and receives a "Please Wait" message, refresh the browser to properly load the page.
Posted Apr 06, 2022 - 08:03 EDT

Investigating

We are currently investigating an issue with login performance into LaunchPad. If a session appears to hang after logging in, refreshing the browser might resolve the issue. As soon as we have more information, we will update this post. Thank you for your patience.
Posted Apr 06, 2022 - 07:35 EDT
This incident affected: Sign in to ClassLink (Active Directory Integration, Google Integration, Azure Integration).