LaunchPad Login Issues

Incident Report for ClassLink

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 11:41 EDT

Monitoring

We believe we have identified and resolved the issue. We will continue to monitor the ensure the issue is fully resolved.
Posted Jun 01, 2026 - 11:24 EDT

Identified

We believe we have identified the issue and are working on a resolution.
Posted Jun 01, 2026 - 10:31 EDT

Update

We are continuing to investigate this issue.
Posted Jun 01, 2026 - 09:27 EDT

Update

We are continuing to investigate this issue.
Posted Jun 01, 2026 - 09:21 EDT

Investigating

Users are experiencing issues logging into LaunchPad. We are currently investigating and will provide an update as soon as possible.
Posted Jun 01, 2026 - 09:14 EDT
This incident affected: LaunchPad (Active Directory Integration, Google Integration, Azure Integration).