My Apps hanging after login

Incident Report for ClassLink

Resolved

This incident has been resolved. My Apps has been restored.
Posted Jan 15, 2021 - 07:59 EST

Monitoring

The issue has been identified with My Apps and the service should be restored.
Posted Jan 15, 2021 - 07:51 EST

Investigating

We've identified an issue with My Apps hanging after logging in to ClassLink.
Posted Jan 15, 2021 - 07:42 EST
This incident affected: My Apps (My Classes).