My Apps Login Issues

Incident Report for ClassLink

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 18:44 EDT

Monitoring

We’ve identified and resolved the issue affecting My Apps. The service should now be fully restored, and our team is monitoring closely to ensure continued stability.

Thank you for your patience while we worked to resolve this.
Posted Oct 27, 2025 - 18:24 EDT

Investigating

We are currently aware of issues surrounding logging in to My Apps. Our team is actively investigating the issue and working to restore full functionality as quickly as possible.

We’ll provide updates as more information becomes available. Thank you for your patience and understanding.
Posted Oct 27, 2025 - 18:06 EDT
This incident affected: My Apps (My Apps).