Monitoring Google Login Issues

Incident Report for ClassLink

Resolved

This issue should now be resolved. For further details and ongoing updates from Google, please view their incident report here: https://www.google.com/appsstatus/dashboard/incidents/5V5yK8N8heBKnmdqS1eW
Posted Sep 18, 2025 - 12:46 EDT

Monitoring

Google has identified the cause of the issue and pushed a fix out at 11:30am EST. We are continuing to monitor the situation.
Posted Sep 18, 2025 - 12:14 EDT

Investigating

Google, which is used by some to login to ClassLink, is currently experiencing an outage. This is primarily impacting Chromebooks. We will let you know when this issue is resolved by Google.
Posted Sep 18, 2025 - 11:41 EDT
This incident affected: Sign in to ClassLink (Google Integration).