Amazon S3 Experiencing Issues
Incident Report for ClassLink
Resolved
Looks like things are back to normal. We'll continue to monitor https://status.aws.amazon.com/ . If AWS services experience another issue, we'll keep everyone posted. Thank you for your patience.
Posted 5 months ago. Sep 14, 2017 - 16:05 EDT
Update
Hello, good news...

The latest from AWS:

12:49 PM PDT We are now seeing recovery in the throttle error rates accessing Amazon S3. We have identified the root cause and have taken actions to prevent recurrence.

We're checking our services - initial checks are good. We'll keep everyone posted.
Posted 5 months ago. Sep 14, 2017 - 15:54 EDT
Monitoring
We are still monitoring Amazon's status page https://status.aws.amazon.com/ . 4 more events have been posted in the last 15 minutes.

Other websites and services hosted by AWS are likely to have issues as well.
Posted 5 months ago. Sep 14, 2017 - 15:47 EDT
Identified
Hello,

ClassLink custom app icons, wallpapers, avatars might not load due to issues with Amazon Web Services (S3). Amazon has posted this on their status page and is actively working on fixing the issue.

Latest from Amazon:
11:58 AM PDT We are investigating increased error rates for Amazon S3 requests in the US-EAST-1 Region.
12:21 PM PDT We can confirm that some customers are receiving throttling errors accessing S3. We are currently investigating the root cause.

For more, go to https://status.aws.amazon.com/

If you have any questions or concerns, please contact us at helpdesk@classlink.com
Posted 5 months ago. Sep 14, 2017 - 15:24 EDT