Slow Logins
Incident Report for ClassLink
Resolved
The issue has been resolved and service is restored.
Posted over 1 year ago. Mar 21, 2017 - 09:08 EDT
Investigating
We've identified an issue that is causing slow logins. The team is working to restore logins as quickly as possible.
Posted over 1 year ago. Mar 21, 2017 - 08:32 EDT