Florida ISP Issues
Incident Report for ClassLink
Resolved
We received reports from several Florida School Districts that their ClassLink service has been restored. Thank you, everyone.
Posted 9 months ago. Mar 02, 2018 - 16:34 EST
Update
It appears service is slowly being restored to the Florida area. We will continue to monitor the situation. Please contact helpdesk@classlink.com for further questions.

http://downdetector.com/status/spectrum/map/
Posted 9 months ago. Mar 02, 2018 - 15:40 EST
Monitoring
We noticed several Florida School Districts reporting increased latency and we are receiving alerts for connectivity. Spectrum is having major issues right now in Florida. This is only affecting districts in Florida.

http://downdetector.com/status/spectrum/map/

We will continue to monitor the situation and be in contact with our Florida districts. Please contact helpdesk@classlink.com if you have further questions.
Posted 9 months ago. Mar 02, 2018 - 15:21 EST