Slow logins
Incident Report for ClassLink
Resolved
System is back to normal. We'll continue to monitor the system and send an update if anything else pops up. Thanks for your patience.
Posted almost 2 years ago. Jan 09, 2017 - 18:27 EST
Monitoring
We've identified the issue and have addressed it. The team is closely monitoring the system but everything should be back to normal..
Posted almost 2 years ago. Jan 09, 2017 - 15:55 EST
Investigating
We're investigating reports of slowness in accessing and logging into ClassLink.
Posted almost 2 years ago. Jan 09, 2017 - 15:16 EST